در این ایام کرونائی که همه مجبور به دورکاری هستیم ، ما با دو شماره 09374655385 و 09118689448 بصورت تلفنی در انتظار شنیدن صدای گرمتان هستیم .

مجله آموزشی وهاب آنلاین

دنیای بزرگ آموزشی وهاب آنلاین

هاست whmcs چه پیش نیازهایی باید داشته باشد

هاست whmcs چه پیش نیازهایی باید داشته باشد

خلاصه : هاست whmcs چه پیش نیازهایی باید داشته باشد

این روزها کاربران سوالاتی مبنی بر اینکه هاست whmcs چه پیش نیازهایی باید داشته باشد را مطرح میکنند و با اینکه اکثرا به آن پاسخ میدهند اما تمام پیش نیازهای whmcs را نمیدانند و همین باعث شده است از من بپرس این هفته وهاب آنلاین را به این موضوع اختصاص دهیم .

این روزها کاربران سوالاتی مبنی بر اینکه هاست whmcs چه پیش نیازهایی باید داشته باشد را مطرح میکنند و با اینکه اکثرا به آن پاسخ میدهند اما تمام پیش نیازهای whmcs را نمیدانند و همین باعث شده است از من بپرس این هفته مجله وهاب آنلاین را به این موضوع اختصاص دهیم .

هاست whmcs چه پیش نیازهایی باید داشته باشد

همانطور که میدانید هر سیستمی برای نصب نیاز به پیش نیازهایی دارد . این پیش نیازها با توجه به اینکه برنامه نویس از چه امکاناتی در php استفاده میکند متغییر می باشد . مثلا اگر برنامه نویس از Curl استفاده کرده باشد فعال بودن CURL در سرور از الزامات می باشد و یا اگر از fopen استفاده کرده باشد فعال بودن این تابع در سرور بسیار حیاتی خواهد بود . تعداد توابع php بسیار زیاد است و البته یک برنامه نویس از همه آنها استفاده نخواهد کرد .

تقریبا بیش از 80 درصد توابع به صورت پیشفرض در سرورها فعال هستند و مابقی با توجه به نیاز کاربر و نوع مدیریت سرور ، توسط مدیر آن سرور فعال خواهد شد . در cPanel ماژول selector ورژن این امکان را برای کاربران فعال میکند که بتوانند تابع های مشخص شده توسط مدیر سرور را در هاست خود فعال یا غیرفعال نمایند .

اما از آنجایی که برای whmcs یک سری پیش نیازها الزامی می باشد بهتر است قبل از خرید هاست و نصب و کانفیگ whmcs از مدیریت سرور سوال بپرسید که آیا هاست آنها این موارد را پشتیبانی می کند یا خیر.

در زیر ما لیست پیش نیازهای whmcs را به صورت کامل ذکر کرده ایم و شما می توانید قبل از خرید هاست از هاستینگ خود در مورد این پیش نیازها سوال بپرسید .

لیست پیش نیازهای whmcs

این پیشنیازها برای نسخه 7.6 به بالا الزامی می باشد .

ورژن php : حداقل 7.2 و پیشنهاد whmcs نسخه 7.3 یا 7.4 می باشد

الزاماتحداقلپیشنهاد
نسخه php7.27.3 یا 7.4
PHP Memory Limit64MB128MB
PHP Database ExtensionPDOPDO
PHP ExtensionsCurl with SSL
GD2 Image Library
JSON Support
XML
Iconv
MBString
GMP
OpenSSL
BC Math
Intl
MySQL Version5.2.0آخرین نسخه
Ioncube Loaders10.2.0نسخه آخر 10.x

سایر موارد در نسخه های whmcs به شرح زیر می باشد

whmcs نسخه 7.0 تا نسخه 7.4 از php 5.6 و 7.0 پشتیبانی می کند
whmcs نسخه 7.2 از php نسخه 5.6,7.0,7.1 و 7.2 پشتیبانی می کند
whmcs نسخه 7.6 تا نسخه 7.10 از php نسخه 5.6, 7.0, 7.1, 7.2 و 7.3 پشتیبانی می کند .
whmcs نسخه 8.0 تنها از php 7.2 و 7.3 و 7.4 پشتیبانی خواهد کرد

موارد ذکر شده حداقل پیش نیازهای سیستم می باشند و به شما پیشنهاد میکنیم همیشه آخرین نسخه های هر کدام از موارد بالا را در سرور خود داشته باشید .

همچنین شما در هر زمانی می توانید آخرین پیشنهازهای whmcs را از وبسایت اصلی خود whmcs به این آدرس مشاهده نمایید . در اطلاعات همین صفحه مواردی آمده است که بسیار مهم هستند و نوشتن آنها در زیر خالی از لطف نخواهد بود .

نصب whmcs بر روی سیستم عامل لینوکس به همراه وبسرور آپاچی توسط خود whmcs پیشنهاد شده است و در مابقی وب سرورها ممکن است اشکالاتی در اجرای این سیستم وجود داشته باشد .

استفاده از حافظه بسته به نوع کارکرد شما از سیستم متفاوت خواهد بود . در برخی موارد ممکن است شما نیاز به حافظه بیشتر و گاهی نیز داشتن حداقل امکانات برای شما کافی می باشد .

نصب و فعال بودن Open SSL آخرین نسخه در سرور whmcs بسیار الزامی می باشد .

نوشته شده در 16ام مرداد 1399 نویسنده : وهاب آنلاین بروزرسانی : 16ام مرداد 1399
پیشنهاد میکنیم ببینید :


دیدگاهی ثبت نشده است